ウインドウメニュー

ツールウインドウの配置変更や、ウインドウのレイアウトを保存することができます。

fig


メニューリスト

fig

項目 内容
フローティング ドッキングされているツールウィンドウをフローティング化します。
ドッキング フローティング化されているツールウィンドウをドッキングします。
閉じる 選択中のツールウインドウを閉じます。
ウインドウレイアウトを保存 現在のツールウインドウのレイアウトを保存することができます。
ウインドウレイアウトを適用 保存したツールウインドウのレイアウトを再現します。
ウインドウレイアウトの管理 保存したウインドウレイアウト名を変更したり、不要になったレイアウトを削除することができます。
ウインドウレイアウトのリセット ツールウインドウレイアウトを初期設定に戻します。
タブを全て閉じる ファイル編集ウインドウで開かれているタブを全て閉じます。
ファイル編集タブの選択 ファイル編集ウインドウで、開いているファイル名が全て表示されます。
クリックすると選択したファイルの編集タブがアクティブになります。

ドッキングウィンドウ

サイディームではウィンドウを自由に配置することができます。

移動させたいウィンドウのタイトルバーをドラッグすることで移動させることができます。
配置する場合はドロップすることで配置することができます。

images

また移動時には下記のような移動先を指示する十字のパネルが表示されます。
十字パネルにドロップすることで、指示された場所に配置することができます。

images


ツールウィンドウの共通機能

ツールウィンドウはオプションとして、以下の共通機能を持っています。

fig

名称 機能
フローティング ドッキングされているツールウィンドウをフローティング化します。
ドッキング フローティング化されているツールウィンドウをドッキングします。
タブ付きドキュメントとしてドッキング タブ付きドキュメントとしてドッキングします。。
ドキュメントウィンドウ内でタブとして表示されます。
自動的に隠す ツールウィンドウからカーソルが外れたとき、自動的に隠す機能を有効にします。
ツールウィンドウの画鋲アイコンで切り替えることも可能です。
閉じる ツールウィンドウを閉じます。
ツールウィンドウの×アイコンでも閉じることができます。
閉じたツールウィンドウを再び開くには、メニューバー内の表示メニューからウィンドウを選択します。